Back to overview
Degraded

Investigating database slowdown

Jul 28 at 08:38am PDT
Affected services
Production Core Services (api.withvector.com)

Resolved
Jul 28 at 11:04am PDT

All systems have recovered.

Updated
Jul 28 at 11:03am PDT

We have recovered. All services should be running normally at this time.

Updated
Jul 28 at 09:23am PDT

We’re seeing recovery from the database slowdown, though some delays may continue as we catch up on pending requests. Thanks for your patience — we’re monitoring closely.

Updated
Jul 28 at 09:03am PDT

We've identified the cause of the database slowdown and are actively working on mitigation to restore normal performance. We'll continue to share updates as we make progress.

Created
Jul 28 at 08:38am PDT

We are investigating a current slowdown. Some database queries are taking longer to respond than normal. We are actively investigating.